czwartek, 15 kwietnia 2010

Google Chrome ostrzega!

Niedawno zauważyłem, że podczas pobierania pakietu deb, moja chromka ostrzega mnie, że plik tego typu może uszkodzić komputer.  Wcześniej taki komunikat pojawiał się tylko podczas próby zapisania plików exe. Według mnie jest to dobry pomysł. Nie powinien on jednak straszyć użytkowników Linuksa, a tylko uświadomić o potencjalnym zagrożeniu. Rzadko zdarza się, że ściągamy pakiety bezpośrednio przez przeglądarkę. Z reguły robi to za nas któryś z menedżerów pakietów. Istnieje więc możliwość, że pakiet został zmanipulowany, a jego instalacja, która jak wiemy odbywa się z uprawnieniami roota, może uszkodzić nasz system. Warto wówczas sprawdzić pochodzenie pakietu.

2 komentarze:

xeros pisze...

No takie ostrzeżenia są już w Chromium od jakiegoś czasu, a co do pobierania pakietów przez przeglądarkę to IMO może nie aż tak popularne jak repozytoria, ale również popularne w przypadku instalacji pakietów, dla których nie założono repozytoriów.

linux pisze...

Fakt, też mi się to rzuciło w oczy. Ciekawe rozwiązanie dobrze świadczące o twórcach przeglądarki.

© 2010 Tomasz Dudzik